Servage Magazine

Information about YOUR hosting company – where we give you a clear picture of what we think and do!

WordPress 5.2 is here – higher requirements for PHP versions

Thursday, May 23rd, 2019 by Helge

In the beginning of May, the latest WordPress version 5.2 or Jaco was released (named after the revolutionary jazz bassist Jaco Pastorius). In addition to the usual fine-tuning of security and stability, WordPress 5.2 also contains a lot of new useful functions.wp52betafeatured-180x180

Worth mentioning is, for example, that the WordPress team built on Site Health, a set of tools that focus on security and page speed introduced in version 5.1, with the site Health Check, which facilitates troubleshooting common configuration problems. Site Health Check also enables developers to more easily include debugging information for anyone who manages the site. There are also a number of useful news for developers, which you can read more about here (general news) and here (privacy-focused news).

Perhaps the single largest new security feature is that WordPress has now added support for cryptographically signed updates. With WordPress 5.2, the WordPress team will digitally sign their update packages with the Ed25519 public key signature system, allowing a local installation to verify the authenticity of the update package before being applied to a local site. Adding support for cryptographically signed updates is an important step in preventing malicious actors from performing so-called “supply chain” attacks on all WordPress websites on the Internet, a risk that security companies warned for over two years.

Another security-related news is PHP Error Protection, an administrator-focused update that allows you to securely manage and fix fatal PHP errors without having access to your own developer resources.

Of course, you find WordPress in your Servage application installer. Check THIS helpdesk page to find out how to use that tool and how to install WordPress (and many other tools) with few clicks only.

The probably most important PHP change to keep track of is, however, that the new version also makes a “bump” upwards in which PHP versions are supported. In WordPress 5.2, the lowest supported PHP version is 5.6.20 – which means that if you are currently running a lower version then update PHP before you install WordPress 5.2.Via your Servage control panel, you can easily assign higher PHP versions to your existing installation. Please check the guideline HERE to find out how that works.

We always recommend that you always update to the latest version – both from a safety point of view and for better overall performance and the ability to run new functions.

WordPress 5.2 is here - higher requirements for PHP versions, 5.0 out of 5 based on 7 ratings
Categories: Guides & Tutorials
You can follow any responses to this entry through the RSS 2.0 feed. You can leave a response, or trackback from your own site.

No comments yet (leave a comment)

You are welcome to initiate a conversation about this blog entry.

Leave a comment

You must be logged in to post a comment.